• Welcome to IPTV Community! You need login/register in-order to access forum without restriction.

iPlayTV app

neonnox

New Member
Sep 29, 2017
85
13
8
40
I have a request i wanted to ask you about @iPlayTV, i have two AppleTVs at home in separate rooms and when i was watching a TV-show last week, i switched back and forth between the two ATVs/displays and what i noticed was that the "seen" status of an episode will not keep in sync between the two ATVs both running the same version of the iPlayTV app. So for example, if i watched episode 2 on ATV 1 and then watch epsisode 3 on ATV 2, the ATV 1 will still show only seen status for episode 2 instead of also 3.

It would be great if the seen status could be synced between devices running the app. Do you think you can implement this in next version?
 

kelix

New Member
Jan 17, 2020
11
3
3
I have a request i wanted to ask you about @iPlayTV, i have two AppleTVs at home in separate rooms and when i was watching a TV-show last week, i switched back and forth between the two ATVs/displays and what i noticed was that the "seen" status of an episode will not keep in sync between the two ATVs both running the same version of the iPlayTV app. So for example, if i watched episode 2 on ATV 1 and then watch epsisode 3 on ATV 2, the ATV 1 will still show only seen status for episode 2 instead of also 3.

It would be great if the seen status could be synced between devices running the app. Do you think you can implement this in next version?
agreed, syncing not only favourite and channels, but also watched status for VOD would make life much easier! pls do this via iCloud! @iPlayTV
 

notandigg

New Member
Feb 7, 2020
9
2
3
Are others having problems reloading/refreshing channel list? I get an error a couple of times until it suddenly works. Always an error "Can't download EPG file. Check if you have internet and if the URL is right"
 

Falkens

New Member
Mar 31, 2020
2
1
3
Sweden
Are others having problems reloading/refreshing channel list? I get an error a couple of times until it suddenly works. Always an error "Can't download EPG file. Check if you have internet and if the URL is right"
I have got it too but for me it has never started to work. But when I test with the GSE app it works immediately
 

notandigg

New Member
Feb 7, 2020
9
2
3
The latest update is great and I think it has fixed the problem which has really made it difficult to use the app. I really love the new features too great job
 

fantastic_chicken

New Member
Jan 19, 2019
11
2
3
Did something change how the EPG is synced and updated in the last version 3.2.0?

Since version 3.1.7 released Feb 12, 2020 the EPG have worked perfectly for me. Each time I've opened the app the EPG have been populated and up-to-date, I don't think I've needed to manually refresh it a single time when using version 3.17.

But then a few days ago the EPG was suddenly empty for the first time in forever, I did a manual refresh and it was populated. Then yesterday the EPG was gone again and I had to manually refresh, and today the same thing. At first I thought it was my EPG server that went down since the last version of iPlay fixed all the EPG issues I had. But then I saw that version 3.2.0 was released a week ago. It can't be a coincide that it goes from working flawlessly for almost two months to going back to being broken the same week as the new version is released.

So is the EPG broken once again in 3.2.0 for anyone other than me?
 

notandigg

New Member
Feb 7, 2020
9
2
3
Did something change how the EPG is synced and updated in the last version 3.2.0?

Since version 3.1.7 released Feb 12, 2020 the EPG have worked perfectly for me. Each time I've opened the app the EPG have been populated and up-to-date, I don't think I've needed to manually refresh it a single time when using version 3.17.

But then a few days ago the EPG was suddenly empty for the first time in forever, I did a manual refresh and it was populated. Then yesterday the EPG was gone again and I had to manually refresh, and today the same thing. At first I thought it was my EPG server that went down since the last version of iPlay fixed all the EPG issues I had. But then I saw that version 3.2.0 was released a week ago. It can't be a coincide that it goes from working flawlessly for almost two months to going back to being broken the same week as the new version is released.

So is the EPG broken once again in 3.2.0 for anyone other than me?
Actually the app has never worked so well for me as it does now after latest update. Before last update I had to refresh multiple times because it always gave me an error not being able to access the url or some other error. So I was nearly giving up on the app but after latest update everything is working perfectly and no problems and I hope it stays that way since it was really going on my nerves I thought it had always something to do with the server but it was the app.
 

notandigg

New Member
Feb 7, 2020
9
2
3
Actually the app has never worked so well for me as it does now after latest update. Before last update I had to refresh multiple times because it always gave me an error not being able to access the url or some other error. So I was nearly giving up on the app but after latest update everything is working perfectly and no problems and I hope it stays that way since it was really going on my nerves I thought it had always something to do with the server but it was the app.
But I do understand your frustration. It is irritating when it is not working. Hope you get it to work properly again. Have you tried setting it up using XTREAM server? That seems to be working better than remote playlist file. If you haven't set it up that way.
 

neonnox

New Member
Sep 29, 2017
85
13
8
40
Did something change how the EPG is synced and updated in the last version 3.2.0?

Since version 3.1.7 released Feb 12, 2020 the EPG have worked perfectly for me. Each time I've opened the app the EPG have been populated and up-to-date, I don't think I've needed to manually refresh it a single time when using version 3.17.

But then a few days ago the EPG was suddenly empty for the first time in forever, I did a manual refresh and it was populated. Then yesterday the EPG was gone again and I had to manually refresh, and today the same thing. At first I thought it was my EPG server that went down since the last version of iPlay fixed all the EPG issues I had. But then I saw that version 3.2.0 was released a week ago. It can't be a coincide that it goes from working flawlessly for almost two months to going back to being broken the same week as the new version is released.

So is the EPG broken once again in 3.2.0 for anyone other than me?
How do you know it’s the app that caused the EPG issues? Did you try another app at the same time and if so, did you have the same EPG issue then too?

My point is, it could have been a source issue that caused the problem. I’ve had a few occasions lately where the EPG wouldn’t work but turned out it was problem with my source (provider).

I am really liking the latest beta, no issues at all here.
 

fantastic_chicken

New Member
Jan 19, 2019
11
2
3
How do you know it’s the app that caused the EPG issues? Did you try another app at the same time and if so, did you have the same EPG issue then too?

My point is, it could have been a source issue that caused the problem. I’ve had a few occasions lately where the EPG wouldn’t work but turned out it was problem with my source (provider).

I am really liking the latest beta, no issues at all here.
Even if there were issues with the EPG provider I think it looks more like it's iPlay that isn't able to store the EPG data that it downloads persistently. I don't know the details what was changed before that fixed the EPG for me before, but I think I read something about storing the EPG using iCloud so tvOS didn't delete the downloaded data whenever it felt like it.

The EPG source I'm using contains data for at least the upcoming 24 hours, and when manually refreshed I can see the scheduled for a channel for the next 24 hours in the app so I know that it was loaded and "should" be there until roughly the same time the next day. But if I open iPlayTV 12-13 hours later the entire EPG is empty again.

So I think, at least for me, iPlay is no longer using iCloud to store the EPG in the latest AppStore version. Anyone know if it's possible to verify if iCloud is used and/or actually see the files stored there?
 

fantastic_chicken

New Member
Jan 19, 2019
11
2
3
The AppleTV did ask me to sign in again to my AppleID (using a specific one for the AppleTV) earlier this week, didn't think much of it at the time but perhaps it's related. When I tested now I couldn't sign in to icloud.com with it, it threw me an error. So now I've tried to sign out from all devices and signed in again and I'm now able to login to icloud.com.

I guess I'll find out within a day or two if it fixed the issue for me. At the moment it's reported that I'm using less than 1MB on iCloud with the account, so I guess so far iPlay is not storing any EPG data there since the EPG file is over 50MB. But perhaps there is a delay and not instant.
 

fantastic_chicken

New Member
Jan 19, 2019
11
2
3
No change really since the last post for me, I still need to refresh the EGP manually pretty much everyday. I saw in the 3.1.6 release note that iCloud Sync was removed due to issues, so perhaps it was never the reason it worked or me in 3.1.7.

I don't think the "Auto update EPG in background" is ever happening for me in 3.2.0. So far for the last 10 days, I think it's only one time that the EPG was empty and after a while after using the app populated without me manually refreshing it, and this one time I'm actually unsure if I did a refresh without thinking about it.
 

neonnox

New Member
Sep 29, 2017
85
13
8
40
Question for you @iPlayTV , in my home cinema, i have a screen with a 2.35:1 aspect ratio (also known as cinemascope) and when i watch VOD movies in this aspect ratio, the subtitles ends up outside of the image which is kind of annoying. Is there any way you can add an option for the subtitles to shift them up or down?

As you can see in the images below, when i have the image zoomed in the subtitles can be seen but they are located both in the active image area and in the black bars but when i zoom out to fill my screen, the subs ends up outside of the image. If there was a way to move the subs up in the image area, i could still see them when i have zoomed out and filled my screen.

Any idea if this is possible?IMG_4139.jpgIMG_4138.jpg
 

neonnox

New Member
Sep 29, 2017
85
13
8
40
Tried the new beta and really nice to see a favorite section for TV-shows & movies finally added:) Works great!
 

notandigg

New Member
Feb 7, 2020
9
2
3
Tried the new beta and really nice to see a favorite section for TV-shows & movies finally added:) Works great!
It would also be great to have favorites grouped by country as well on live tv. Because now it is all in one pile and grouped by added